GitHub header

Incident with Copilot AI Model Providers

Incident Report for GitHub

Update

The external AI model provider is continuing to investigate.
Posted Jul 29, 2026 - 21:08 UTC

Update

The external AI model provider has identified the issue and is working to resolve.
Posted Jul 29, 2026 - 20:38 UTC

Update

We are investigating increased error rates affecting GitHub Copilot requests to external AI model providers. Some users may experience failures or degraded performance when using Copilot features.
Posted Jul 29, 2026 - 20:18 UTC

Update

We are seeing increased error rates with requests to specific model providers.
Posted Jul 29, 2026 - 20:07 UTC

Investigating

We are investigating reports of degraded performance for Copilot AI Model Providers
Posted Jul 29, 2026 - 20:07 UTC
This incident affects: Copilot AI Model Providers.