GitHub header
We are investigating reports of degraded performance.
Incident Report for GitHub
Resolved
On January 9 between 1:06 and 5:43 UTC, no audit log events were streamed for customers that have that enabled. All events that happened during this time were delivered after the issue was mitigated. The event delivery was failing due to a data shape issue, with a streaming configuration linked to a soft-deleted Enterprise causing a runtime error for a backend service. This was mitigated by removing that configuration. Since the incident, we have improved our detection of these errors and ensured support for similar scenarios.
Posted Jan 09, 2024 - 05:44 UTC
Update
Audit logs streaming is currently unavailable due to a misconfiguration issue. The root cause is understood and our engineers will be updating the broken configuration shortly.
Posted Jan 09, 2024 - 05:40 UTC
Investigating
We are currently investigating this issue.
Posted Jan 09, 2024 - 04:59 UTC