Creation of new Pull Request threads (including line and file comments) continues to be affected.
Top-level comments on pull requests still function and should remain usable during recovery. Opening and merging pull requests, actions, and other pull request operations remain functional.
A mitigation is being applied. Recovery is expected to be gradual, with complete recovery expected by 8:00pm UTC.
Posted May 06, 2026 - 16:20 UTC
Update
Pull Requests is experiencing degraded availability. We are continuing to investigate.
Posted May 06, 2026 - 16:07 UTC
Update
Creation of new Pull Request threads (including line and file comments) continues to be affected. We have identified the cause of the issue and have started taking steps to mitigate this issue.
Posted May 06, 2026 - 15:55 UTC
Update
We are investigating failures for new thread creation on Pull Requests. Responses to existing pull request threads are unaffected.
Posted May 06, 2026 - 15:28 UTC
Investigating
We are investigating reports of degraded performance for Pull Requests