GitHub header
Incident with Actions
Incident Report for GitHub
Resolved
On May 13, 2024, between 19:03 UTC and 19:57 UTC, some customers experienced delays in receiving status updates for in-progress GitHub Actions workflow runs. The root cause was identified to be a bug in the logic for checking the state of a configuration which would only manifest under very specific conditions and cause exceptions. These exceptions impacted the backend process for handling workflow run status updates and caused jobs with any annotations to not get updated properly. Jobs without any annotations were not affected. The affected jobs during the incident will get marked as failed after 24 hours, and affected customers will need to manually retry the jobs they want to execute.

We resolved the incident by reverting the problematic change. We are enhancing our process for deploying changes and reassessing our monitoring of relevant subsystems to prevent similar issues in the future.
Posted May 13, 2024 - 20:10 UTC
Update
We are seeing signs of recovery for actions jobs
Posted May 13, 2024 - 20:10 UTC
Investigating
We are investigating reports of degraded performance for Actions
Posted May 13, 2024 - 19:51 UTC
This incident affected: Actions.