GitHub header
We are investigating reports of degraded performance.
Incident Report for GitHub
Resolved
On Monday, February 26th, from 20:45 UTC to 21:39 UTC, GitHub Packages reported an outage indicating a degradation in GitHub Container Registry and NPM package upload functionality. Upon investigation, we found a misconfigured observability metric which inadvertently pulled in data from a newly provisioned test environment. All failures being reported were traced back to this test environment. We confirmed that there was no real customer impact to GitHub Packages during this incident. We have since reconfigured our observability metrics to accurately report based on environment.
Posted Feb 26, 2024 - 21:40 UTC
Update
We are seeing some recovery in NPM and GitHub Container Registry functionality, but are maintaining red status until we are certain issues won’t recur.
Posted Feb 26, 2024 - 21:20 UTC
Update
NPM and GitHub Container Registry services are degraded, particularly the upload functionality. Investigation is underway.
Posted Feb 26, 2024 - 21:03 UTC
Investigating
We are currently investigating this issue.
Posted Feb 26, 2024 - 21:01 UTC