GitHub header
Incident with Copilot
Incident Report for GitHub
Resolved
On December 1st, GitHub’s internal metrics highlighted increased latency for Copilot Chat requests. We declared an incident while investigating and discovered that the issue was only affecting GitHub employees. It was caused by a performance issue in a recently enabled feature that was only available internally.

We resolved the issue by disabling the feature.

The team has invested in improved telemetry, monitoring, and playbooks for Copilot Chat to ensure we can accurately assess impact and respond appropriately to alerting.
Posted Dec 01, 2023 - 18:16 UTC
Update
A small percentage of Copilot Chat users are still experiencing long request times and errors. We are still investigating to determine the root cause.
Posted Dec 01, 2023 - 17:36 UTC
Update
Some customers are experiencing higher latency for Copilot Chat. We are continuing our investigation.
Posted Dec 01, 2023 - 16:41 UTC
Update
Copilot is experiencing degraded performance. We are continuing to investigate.
Posted Dec 01, 2023 - 15:55 UTC
Update
We are investigating reports that that some customers are experiencing increased latency and failed requests for Copilot Chat.
Posted Dec 01, 2023 - 15:53 UTC
Investigating
We are currently investigating this issue.
Posted Dec 01, 2023 - 15:49 UTC
This incident affected: Copilot.