GitHub header
Incident with Packages
Incident Report for GitHub
Resolved
On June 6, 2024 between 03:29 and 04:19 UTC, the service responsible for the Maven package registry was degraded. This affected GitHub customers who were trying to upload packages to the Maven package registry.

We observed increased database pressure due to bulk operations in progress, and at 04:19 UTC, the Maven upload issues resolved when those bulk operations finished. We're continuing to assess any additional compounding factors.

We are working on improving our thresholds for existing alerts to reduce our time to detection and mitigation of issues like this one in the future.
Posted Jun 06, 2024 - 04:43 UTC
Update
We were alerted to problems in maven uploads. These have now improved, and we're continuing to monitor and investigate.
Posted Jun 06, 2024 - 04:38 UTC
Update
We are investigating reports of issues with Packages. We will continue to keep users updated on progress towards mitigation.
Posted Jun 06, 2024 - 04:21 UTC
Investigating
We are investigating reports of degraded performance for Packages
Posted Jun 06, 2024 - 04:21 UTC
This incident affected: Packages.