GitHub header

Incident with Issues and Git Operations

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Aug 21, 2025 - 06:58 UTC

Update

Git Operations is operating normally.
Posted Aug 21, 2025 - 06:58 UTC

Update

Issues is operating normally.
Posted Aug 21, 2025 - 06:58 UTC

Update

The errors in our database infrastructure were related to some maintenance events that had more impact than expected. We will provide more details and follow ups when we post a public summary for this incident in the coming days. All impact to customers is resolved.
Posted Aug 21, 2025 - 06:58 UTC

Update

We saw a brief spike in failures related to some of our database infrastructure. Everything has recovered but we are continuing to investigate to ensure we don't see any reoccurrence.
Posted Aug 21, 2025 - 06:39 UTC

Update

Approximately 1% of API and web requests are seeing intermittent errors. Some customers may see some push errors. We are currently investigating.
Posted Aug 21, 2025 - 06:30 UTC

Investigating

We are investigating reports of degraded performance for Git Operations and Issues
Posted Aug 21, 2025 - 06:25 UTC
This incident affected: Git Operations and Issues.