GitHub header

Multiple services are affected, service degradation

Incident Report for GitHub

Update

We are back to queueing Actions workflow runs at nominal rates and we are monitoring the clearing of queued runs during the incident.
Posted Mar 05, 2026 - 17:48 UTC

Update

We have applied mitigations for connection failures across backend resources and we are observing a recovery in queueing Actions workflow runs.
Posted Mar 05, 2026 - 17:25 UTC

Update

We are observing delays in queuing Actions workflow runs. We’re still investigating the causes of these delays.
Posted Mar 05, 2026 - 16:52 UTC

Update

Webhooks is experiencing degraded availability. We are continuing to investigate.
Posted Mar 05, 2026 - 16:47 UTC

Update

Actions is experiencing degraded availability. We are continuing to investigate.
Posted Mar 05, 2026 - 16:41 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Mar 05, 2026 - 16:35 UTC
This incident affects: Webhooks and Actions.