GitHub header

Incident with Actions

Incident Report for GitHub

Update

We've applied a mitigation to fix the issues with queuing and running Actions jobs. We are seeing improvements in telemetry and are monitoring for full recovery.
Posted May 20, 2026 - 18:17 UTC

Monitoring

The degradation affecting Actions has been mitigated. We are monitoring to ensure stability.
Posted May 20, 2026 - 17:52 UTC

Update

A subset of runners are taking longer than expected to connect, which may delay some jobs from beginning execution. We are actively working to mitigate the issue.
Posted May 20, 2026 - 17:46 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted May 20, 2026 - 16:58 UTC
This incident affects: Actions.