GitHub header
Incident with Copilot
Incident Report for GitHub
Resolved
On May 30th, 2024, between 03:37 PM UTC and 05:14 PM UTC Copilot chat conversations on github.com saw degraded availability, where chat requests referencing files from a repository failed. This was due to an expired security certificate, which required communication to an internal service. Overall, the error rate was 40% on average. Other Copilot chat experiences were unaffected during this time.

The incident was mitigated by rotating the certificate in question.

To prevent future incidents, we are working to reduce our time to detect and have removed certificate-based dependencies between these internal systems in the process.
Posted May 30, 2024 - 17:22 UTC
Update
Copilot is operating normally.
Posted May 30, 2024 - 17:22 UTC
Update
We have rolled out mitigation and fixes appear to be stable. This incident has been resolved.
Posted May 30, 2024 - 17:22 UTC
Update
Copilot is experiencing degraded performance. We are continuing to investigate.
Posted May 30, 2024 - 17:14 UTC
Update
Our CoPilot API is currently experiencing back-end connectivity issues and we are actively engaged in mitigation steps.
Posted May 30, 2024 - 17:14 UTC
Investigating
We are currently investigating this issue.
Posted May 30, 2024 - 17:14 UTC
This incident affected: Copilot.