Between 2025-06-10 12:25 UTC and 2025-06-11 01:51 UTC, GitHub Enterprise Cloud (GHEC) customers with approximately 10,000 or more users, saw performance degradation and 5xx errors when loading the Enterprise Settings’ People management page. Less than 2% of page requests resulted in an error. The issue was caused by a database change that replaced an index required for the page load. The issue was resolved by reverting the database change.
To prevent similar incidents, we are improving the testing and validation process for replacing database indexes.
Posted Jun 11, 2025 - 01:51 UTC
Update
Fix is currently rolling out to production. We will update here once we verify.
Posted Jun 11, 2025 - 01:08 UTC
Update
We are working to deploy the fix for this issue. We will update again once it is deployed and as we monitor recovery.
Posted Jun 10, 2025 - 23:32 UTC
Update
We have the fix ready, once it's ready to deploy we will provide another update confirming that it has resolved the issue.
Posted Jun 10, 2025 - 22:42 UTC
Update
We have identified the solution to the performance issue and are working on the mitigation. Impact continues to be limited to very large enterprise customers when viewing the People page.
Posted Jun 10, 2025 - 21:04 UTC
Update
The mitigation to add a supporting index to improve the performance of the People page did not resolve the issue, and we are continuing to investigate a solution.
Posted Jun 10, 2025 - 20:09 UTC
Update
We are working on the mitigation and anticpate recovery within an hour.
Posted Jun 10, 2025 - 18:57 UTC
Update
Large enterprise customers may encounter issues loading the People page