GitHub header

Degraded REST API Availability

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Jul 17, 2026 - 00:14 UTC

Update

As of 23:46 UTC, the REST API service is reachable and responding to requests normally.
Posted Jul 17, 2026 - 00:14 UTC

Monitoring

The degradation affecting API Requests has been mitigated. We are monitoring to ensure stability.
Posted Jul 17, 2026 - 00:00 UTC

Update

We are continuing to investigate an issue causing approximately 35% of REST API requests to fail.  Based on our current understanding, requests are not consistently reaching the application layer, resulting in failed requests returning HTML responses instead of the expected API response format. We are actively investigating the issue and will provide another update as soon as more information is available.
Posted Jul 16, 2026 - 23:29 UTC

Update

API Requests is experiencing degraded performance. We are continuing to investigate.
Posted Jul 16, 2026 - 22:58 UTC

Update

We are aware of degraded REST API availability and are investigating
Posted Jul 16, 2026 - 22:58 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Jul 16, 2026 - 22:51 UTC
This incident affected: API Requests.