On July 30th, 2024, between 12:15 UTC and 14:22 UTC the Codespaces service was degraded in the UK South and West Europe regions. During this time, approximately 75% of attempts to create or resume Codespaces in these regions were failing.
We mitigated the incident by resolving networking stability issues in these regions.
We are working to improve network resiliency to reduce our time to detection and mitigation of issues like this one in the future.
Posted Jul 30, 2024 - 14:22 UTC
Update
We are starting to see recovery for this issue and are monitoring things closely. We will keep this incident open for now until we are fully confident on complete recovery.
Posted Jul 30, 2024 - 14:16 UTC
Update
We have correlated the impact on Codespaces to an outage with a third party service. We are continuing to investigate ways to reduce impact on our customers while we wait for that outage to be resolved.
Posted Jul 30, 2024 - 14:09 UTC
Update
We are seeing increased failure rates for creation and resumption of Codespaces in the UK South and West Europe regions.
We are working to resolve this issue and will update again soon.
Posted Jul 30, 2024 - 13:47 UTC
Investigating
We are investigating reports of degraded performance for Codespaces