GitHub header

Some Copilot Models Experiencing Degraded Performance

Incident Report for GitHub

Resolved

On July 21, 2025, between 07:20 UTC and 08:00 UTC, the Copilot service experienced degraded availability for Claude 4 requests. 2% of Claude 4 requests failed during this time. The issue was caused by an upstream problem affecting our ability to serve requests.
We mitigated by rerouting capacity and monitoring recovery. We are improving detection and mitigation to reduce future impact.
Posted Jul 21, 2025 - 07:50 UTC

Investigating

We are currently investigating this issue.
Posted Jul 21, 2025 - 07:36 UTC