GitHub header

Delays in commit processing

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Sep 01, 2026 - 16:01 UTC

Update

Time to update pull request diffs have improved to normal thresholds.
Posted Sep 01, 2026 - 16:00 UTC

Update

Diffs in the PR view may be stale for several minutes. We are investigating and scaling up resources.
Posted Sep 01, 2026 - 15:00 UTC

Investigating

We are investigating reports of degraded performance for Pull Requests
Posted Sep 01, 2026 - 15:00 UTC
This incident affected: Pull Requests.