GitHub header

Inconsistent results when using the Haiku 4.5 model

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Oct 28, 2025 - 17:11 UTC

Update

The issues with our upstream model provider have been resolved, and Claude Haiku 4.5 is once again available in Copilot Chat and across IDE integrations.

We will continue monitoring to ensure stability, but mitigation is complete.
Posted Oct 28, 2025 - 17:11 UTC

Update

Usage of the Haiku 4.5 model with Copilot experiences is currently degraded. We are investigating and working to remediate. Other models should be unaffected.
Posted Oct 28, 2025 - 16:42 UTC

Investigating

We are currently investigating this issue.
Posted Oct 28, 2025 - 16:39 UTC