GitHub header

Code search experiencing degraded performance

Incident Report for GitHub

Update

Elevated latency and timeouts for code search is isolated to a single shard experiencing elevated CPU. We are continuing to investigate the cause and steps to mitigate.
Posted Feb 23, 2026 - 21:18 UTC

Update

We are continuing to investigate elevated latency and timeouts for code search.
Posted Feb 23, 2026 - 20:33 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Feb 23, 2026 - 19:59 UTC