The notification delivery backlog has been processed and notifications are now being delivered as expected.
Posted Apr 29, 2025 - 12:52 UTC
Update
New notification deliveries are occuring in a timely manner and we have processed a significant portion of the backlog. Users may still notice delayed delivery of some older notifications.
Posted Apr 29, 2025 - 12:45 UTC
Update
Web and email notifications continue to be delivered successfully and the service is in a healthy state. We are processing the backlog of notification deliveries which are currently as much as 30-60 minutes delayed.
Posted Apr 29, 2025 - 11:57 UTC
Update
We are starting to see signals of recovery with delayed web/email notifications now being dispatched.
The team continue to monitor recovery and ensure return to normal service.
Posted Apr 29, 2025 - 11:09 UTC
Update
We are seeing impact on both web and email notifications with most customers seeing delayed deliveries.
The last incident updated regarding impact on email notifications was incorrect. Email notifications have been experiencing the same delays as web notifications for duration of incident.
We have applied changes to our system and are monitoring to see if these restore normal service. Updates to follow.
Posted Apr 29, 2025 - 10:37 UTC
Update
Web notifications are experiencing delivery delays for the majority of customers. We are working to mitigate impact and restore delivery times back within normal operating bounds.
Email notifications remain unaffected and are delivering as normal.
We will provide futher updates as we have more information.