GitHub header

Incident with Actions

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Jul 08, 2025 - 16:44 UTC

Update

We are seeing complete recovery for Actions. New jobs will run as normal. Some runs initiated during the incident will be left in a stuck state and will not complete.
Posted Jul 08, 2025 - 16:43 UTC

Update

We have scaled out our capacity and customers will begin to see timely updates.
Posted Jul 08, 2025 - 16:29 UTC

Update

Some customers are seeing delays in updates to their runs resulting in missing logs and delayed run status updates. We are investigating the cause of the issue.
Posted Jul 08, 2025 - 16:10 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Jul 08, 2025 - 16:05 UTC
This incident affected: Actions.