This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Oct 09, 2025 - 16:40 UTC
Update
All services have fully recovered.
Posted Oct 09, 2025 - 16:39 UTC
Update
Actions has fully recovered but Notifications is still experiencing delays. We will continue to update as the system is fully restored to normal operation.
Posted Oct 09, 2025 - 16:27 UTC
Update
Actions is operating normally.
Posted Oct 09, 2025 - 16:24 UTC
Update
Pages is operating normally.
Posted Oct 09, 2025 - 16:08 UTC
Update
Git Operations is operating normally.
Posted Oct 09, 2025 - 16:04 UTC
Update
Actions and Notifications are still experiencing delays as we process the backlog. We will continue to update as the system is fully restored to normal operation.
Posted Oct 09, 2025 - 16:02 UTC
Update
Pull Requests is operating normally.
Posted Oct 09, 2025 - 15:51 UTC
Update
Actions is experiencing degraded performance. We are continuing to investigate.
Posted Oct 09, 2025 - 15:48 UTC
Update
We are seeing full recovery in many of our systems, but delays are still expected for actions. We will continue to update as the system is fully restored to normal operation.
Posted Oct 09, 2025 - 15:44 UTC
Update
Webhooks is operating normally.
Posted Oct 09, 2025 - 15:43 UTC
Update
Webhooks is experiencing degraded performance. We are continuing to investigate.
Posted Oct 09, 2025 - 15:40 UTC
Update
Issues is operating normally.
Posted Oct 09, 2025 - 15:39 UTC
Update
Pull Requests is experiencing degraded performance. We are continuing to investigate.
Posted Oct 09, 2025 - 15:38 UTC
Update
API Requests is operating normally.
Posted Oct 09, 2025 - 15:26 UTC
Update
We identified a faulty network component and have removed it from the infrastructure. Recovery has started and we expect full recovery shortly.
Posted Oct 09, 2025 - 15:25 UTC
Update
Pull Requests is experiencing degraded availability. We are continuing to investigate.
Posted Oct 09, 2025 - 15:20 UTC
Update
Git Operations is experiencing degraded performance. We are continuing to investigate.
Posted Oct 09, 2025 - 15:20 UTC
Update
Actions is experiencing degraded availability. We are continuing to investigate.
Posted Oct 09, 2025 - 15:17 UTC
Update
We are investigating widespread reports of delays and increased latency in various services. We will continue to keep users updated on progress toward mitigation.
Posted Oct 09, 2025 - 15:11 UTC
Update
Issues is experiencing degraded availability. We are continuing to investigate.
Posted Oct 09, 2025 - 15:09 UTC
Update
API Requests is experiencing degraded performance. We are continuing to investigate.
Posted Oct 09, 2025 - 15:09 UTC
Update
Pages is experiencing degraded performance. We are continuing to investigate.
Posted Oct 09, 2025 - 15:09 UTC
Update
Actions is experiencing degraded performance. We are continuing to investigate.
Posted Oct 09, 2025 - 14:50 UTC
Investigating
We are investigating reports of degraded availability for Webhooks
Posted Oct 09, 2025 - 14:45 UTC
This incident affected: Git Operations, Webhooks, API Requests, Issues, Pull Requests, Actions, and Pages.