GitHub header

Delay in notification deliveries

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Nov 12, 2025 - 17:39 UTC

Update

We are continuing to monitor our mitigations to delays in notification deliveries. Some users may still experience delays of over 10 minutes.
Posted Nov 12, 2025 - 17:15 UTC

Update

We are continuing to work on mitigating delays in notification deliveries. Some users may still experience delays of over 10 minutes.
Posted Nov 12, 2025 - 15:35 UTC

Update

We are continuing to work on mitigating delays in notification deliveries. Some users may experience delays of over 10 minutes.
Posted Nov 12, 2025 - 14:58 UTC

Update

We are investigating delays of up to 10 minutes in notification deliveries. Our team has identified the likely cause and is actively working to mitigate the issue.
Posted Nov 12, 2025 - 14:25 UTC

Investigating

We are currently investigating this issue.
Posted Nov 12, 2025 - 14:23 UTC