GitHub header
Some GitHub Actions may not run
Incident Report for GitHub
Resolved
On January 9, 2025, between 06:26 and 07:49 UTC, Actions experienced degraded performance, leading to failures in about 1% of workflow runs across ~10k repositories. The failures occurred due to an outage in a dependent service, which disrupted Redis connectivity in the East US 2 region. We mitigated the incident by re-routing Redis traffic out of that region at 07:49 UTC. We continued to monitor service recovery before resolving the incident at 08:30 UTC. We are working to improve our monitoring to reduce our time to detection and mitigation of issues like this one in the future.
Posted Jan 09, 2025 - 08:30 UTC
Update
Actions is operating normally.
Posted Jan 09, 2025 - 08:30 UTC
Update
We have seen recovery of Actions runs for affected repositories. We are verifying all remediations before resolving this incident.
Posted Jan 09, 2025 - 08:17 UTC
Update
We have identified the problem and are proceeding with a fail-over remediation. We anticipate this will allow Actions Runs to proceed for affected repositories.
Posted Jan 09, 2025 - 07:47 UTC
Update
1-2% of repositories may have Actions jobs that are blocked and are not running or will be delayed. We have identified a potential cause. We are confirming and will be working on remediation.
Posted Jan 09, 2025 - 07:17 UTC
Investigating
We are investigating reports of degraded performance for Actions
Posted Jan 09, 2025 - 07:15 UTC
This incident affected: Actions.