GitHub header
Incident with Actions
Incident Report for GitHub
Resolved
On June 11th, 2024 between 20:13 UTC and 21:39 UTC, the GitHub Actions service was degraded. A security-related change applied by one of our third-party providers prevented new customers from onboarding to GitHub Actions and caused an average 28% of Actions jobs to fail.

We mitigated the incident by working with the third-party provider to revert the change and are working with their engineering team to fully understand the root cause. Additionally, we are improving communication between GitHub and our service providers to reduce the time needed to resolve similar issues in the future.
Posted Jun 11, 2024 - 21:39 UTC
Update
We've applied a mitigation to unblock running Actions and are seeing an improvement in our service availability.
Posted Jun 11, 2024 - 21:35 UTC
Update
Customers may see issues running Actions, we are in the process of applying a mitigation to restore our service.
Posted Jun 11, 2024 - 21:16 UTC
Update
Customers may see issues running Actions
Posted Jun 11, 2024 - 20:34 UTC
Investigating
We are investigating reports of degraded performance for Actions and API Requests
Posted Jun 11, 2024 - 20:33 UTC
This incident affected: API Requests and Actions.