GitHub header
We are investigating reports of degraded performance.
Incident Report for GitHub
Resolved
On December 26, 2023, GitHub received a report through our Bug Bounty Program demonstrating a vulnerability which, if exploited, allowed access to credentials within a production container. We fixed this vulnerability on GitHub.com the same day and began rotating all potentially exposed credentials. Through this process we found some flaws in how we rotate certain credentials and are working on improving our credential rotation process. More detail can be found on our blog: https://github.blog/2024-01-16-rotating-credentials-for-github-com-and-new-ghes-patches/
Posted Dec 28, 2023 - 06:57 UTC
Update
We have deployed a fix and email service should be restored shortly.
Posted Dec 28, 2023 - 06:49 UTC
Update
We are experiencing issues sending some pull request, actions and other notification emails. Some emails may not be received as the result of activity on GitHub. Web and mobile push notifications are not affected.
Posted Dec 28, 2023 - 06:48 UTC
Investigating
We are currently investigating this issue.
Posted Dec 28, 2023 - 06:43 UTC