GitHub header

Actions delays in starting runs

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Aug 24, 2026 - 14:34 UTC

Monitoring

The degradation affecting Actions has been mitigated. We are monitoring to ensure stability.
Posted Aug 24, 2026 - 14:26 UTC

Update

Failures while queuing and running Actions jobs for a subset of customers are now resolving. We are monitoring for full recovery.
Posted Aug 24, 2026 - 14:22 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Aug 24, 2026 - 13:56 UTC
This incident affected: Actions.