GitHub header

Incident affecting actions-runner-controller

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Jan 20, 2026 - 16:23 UTC

Update

GitHub Actions customers that use actions-runner-controller are experiencing errors from our APIs that informs auto-scaling. We are investigating the issue and working on mitigating the impact.
Posted Jan 20, 2026 - 16:03 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Jan 20, 2026 - 16:02 UTC
This incident affected: Actions.