GitHub header
Incident with API Requests and Issues
Incident Report for GitHub
Resolved
Our internal search infrastructure experienced increased latency and timeouts between 13:15 and 14:05 UTC leading to some end user timeouts and slow responses for any requests that made use of that subsystem. This included but was not limited to: user search, repository search, releases, and audit logs.

We mitigated the issue by migrating traffic to an older version of our search clusters and are investigating what caused the performance issues in our new clusters.
Posted Nov 07, 2023 - 14:25 UTC
Update
API Requests is operating normally.
Posted Nov 07, 2023 - 14:25 UTC
Update
Response times stabilized back to normal at 13:58 UTC. We are continuing to monitor the slow dependency to ensure it's stable before resolving this incident.
Posted Nov 07, 2023 - 14:15 UTC
Update
We're seeing intermittent spikes in latency of API requests and page loads. We are investigating but do not have an ETA at this time.
Posted Nov 07, 2023 - 14:03 UTC
Update
We are investigating reports of issues with service(s): Issues, API Requests. We will continue to keep users updated on progress towards mitigation.
Posted Nov 07, 2023 - 13:50 UTC
Update
Issues is experiencing degraded performance. We are continuing to investigate.
Posted Nov 07, 2023 - 13:46 UTC
Investigating
We are investigating reports of degraded performance for API Requests
Posted Nov 07, 2023 - 13:44 UTC
This incident affected: API Requests and Issues.