GitHub header

Partial degradation for code scanning default setup and for code quality

Incident Report for GitHub

Update

We are continuing to work on a mitigation to unblock code scanning default setup and code quality features on pull requests.
Posted Apr 20, 2026 - 15:20 UTC

Update

We are currently deploying mitigations that should unblock code scanning default setup and code quality features on pull requests.
Posted Apr 20, 2026 - 14:38 UTC

Update

We are actively working to mitigate an issue affecting code scanning default setup and code quality features on pull requests. Users may experience pull request code scanning and code quality analyses not being triggered on new pull requests. Our engineering team has identified the root cause and working on mitigating the issue.
Posted Apr 20, 2026 - 13:57 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Apr 20, 2026 - 13:28 UTC