GitHub header

Loading avatars might fail for a 0.5% of total users and 100% users around the Arabian Peninsula. We are investigating.

Incident Report for GitHub

Resolved

Between August 21, 2025 at 15:00 UTC, and September 2, 2025 at 15:22 UTC the avatars.githubusercontent.com image service was degraded and failed to display user avatars for users in the Middle East. During this time, avatar images appeared broken on github.com for affected users. On average, this impacted about 82% of users routed through one of our Middle East-based points-of-presence, which represents about 0.14% of global users.

This was due to a configuration change within GitHub's edge infrastructure in the affected region, causing HTTP requests to fail. As a result, image requests returned HTTP 503 errors. The failure to detect the issues was the result of an alerting threshold set too low.

We mitigated the incident by removing the affected site from service, which restored avatar serving for impacted users.

To prevent this from recurring, we have tuned configuration defaults for graceful degradation. We also added new health checks to automatically shift traffic from impacted sites. We are updating our monitoring to prevent undetected errors like this in the future.
Posted Sep 02, 2025 - 15:44 UTC

Investigating

We are currently investigating this issue.
Posted Sep 02, 2025 - 15:17 UTC