GitHub header

Incident with Pull Requests: High percentage of 500s

Incident Report for GitHub

Update

We are seeing recovery in latency and timeouts of requests related to pull requests, even though 500s are still elevated. While we are continuing to investigate, we are applying a mitigation and expect further recovery after it is applied.
Posted Mar 31, 2026 - 16:35 UTC

Update

We are continuing to investigate increased 500 errors affecting GitHub services. You may experience intermittent failures when using Pull Requests and other features. We are actively working to identify and resolve the underlying cause.
Posted Mar 31, 2026 - 16:15 UTC

Update

We are investigating increased 500 errors affecting GitHub services. You may experience intermittent failures when using Pull Requests and other features. We are actively working to identify and resolve the underlying cause.
Posted Mar 31, 2026 - 15:39 UTC

Update

We are seeing a higher than average number of 500s due to timeouts across GitHub services. We have a potential mitigation in flight and are continuing to investigate.
Posted Mar 31, 2026 - 15:06 UTC

Investigating

We are investigating reports of degraded performance for Pull Requests
Posted Mar 31, 2026 - 15:05 UTC
This incident affects: Pull Requests.