GitHub header

Incident with Pages

Incident Report for GitHub

Resolved

On April 6, 2024, between 00:00:00 UTC and 02:20:05 UTC, access to Private Pages on the *.pages.github.io domain was degraded while the deployed TLS certificate was expired. Service was restored by uploading the renewed certificate to our CDN. This was due to a process error and a gap in our alerting. While the certificate was renewed and updated in our internal vault, it was not deployed to the CDN.

We are working to reduce potential for errors in our certificate renewal process as well as adding the *.pages.github.io domain to our existing TLS alerting system.
Posted Apr 06, 2024 - 02:22 UTC

Update

We are investigating issues with private pages due to an expired certificate
Posted Apr 06, 2024 - 01:52 UTC

Investigating

We are investigating reports of degraded performance for Pages
Posted Apr 06, 2024 - 01:52 UTC
This incident affected: Pages.