GitHub header

Incident with Copilot and Actions

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Mar 03, 2026 - 20:09 UTC

Update

We're seeing recovery across all services. We're continuing to monitor for full recovery.
Posted Mar 03, 2026 - 20:06 UTC

Update

Actions is operating normally.
Posted Mar 03, 2026 - 19:55 UTC

Update

Git Operations is operating normally.
Posted Mar 03, 2026 - 19:54 UTC

Update

Git Operations is experiencing degraded availability. We are continuing to investigate.
Posted Mar 03, 2026 - 19:36 UTC

Update

We are seeing recovery across multiple services. Impact is mostly isolated to git operations at this point, we continue to investigate
Posted Mar 03, 2026 - 19:33 UTC

Update

Copilot is operating normally.
Posted Mar 03, 2026 - 19:31 UTC

Update

Pull Requests is operating normally.
Posted Mar 03, 2026 - 19:31 UTC

Update

Pull Requests is experiencing degraded performance. We are continuing to investigate.
Posted Mar 03, 2026 - 19:28 UTC

Update

Issues is operating normally.
Posted Mar 03, 2026 - 19:27 UTC

Update

Webhooks is operating normally.
Posted Mar 03, 2026 - 19:25 UTC

Update

Codespaces is operating normally.
Posted Mar 03, 2026 - 19:25 UTC

Update

Webhooks is experiencing degraded performance. We are continuing to investigate.
Posted Mar 03, 2026 - 19:24 UTC

Update

Issues is experiencing degraded performance. We are continuing to investigate.
Posted Mar 03, 2026 - 19:23 UTC

Update

We've identified the issue and have applied a mitigation. We're seeing recovery of services. We continue to montitor for full recovery.
Posted Mar 03, 2026 - 19:17 UTC

Update

API Requests is operating normally.
Posted Mar 03, 2026 - 19:15 UTC

Update

API Requests is experiencing degraded performance. We are continuing to investigate.
Posted Mar 03, 2026 - 19:14 UTC

Update

Codespaces is experiencing degraded performance. We are continuing to investigate.
Posted Mar 03, 2026 - 19:11 UTC

Update

Pull Requests is experiencing degraded availability. We are continuing to investigate.
Posted Mar 03, 2026 - 19:05 UTC

Update

Webhooks is experiencing degraded availability. We are continuing to investigate.
Posted Mar 03, 2026 - 19:04 UTC

Update

We're seeing some service degradation across GitHub services. We're currently investigating impact.
Posted Mar 03, 2026 - 19:03 UTC

Update

Webhooks is experiencing degraded performance. We are continuing to investigate.
Posted Mar 03, 2026 - 19:02 UTC

Update

Pull Requests is experiencing degraded performance. We are continuing to investigate.
Posted Mar 03, 2026 - 19:00 UTC

Update

API Requests is experiencing degraded availability. We are continuing to investigate.
Posted Mar 03, 2026 - 19:00 UTC

Investigating

We are investigating reports of degraded availability for Actions, Copilot and Issues
Posted Mar 03, 2026 - 18:59 UTC
This incident affected: Git Operations, Webhooks, API Requests, Issues, Pull Requests, Actions, Codespaces, and Copilot.