On November 25th, 2024 between 10:38 UTC and 12:00 UTC the Claude model for GitHub Copilot Chat experienced degraded performance. During the impact, all requests to Claude would result in an immediate error to the user. This was due to upstream errors with one of our infrastructure providers, which have since been mitigated.
We are working with our infrastructure providers to reduce time to detection and implement additional failover options to mitigate issues like this one in the future.
Posted Nov 25, 2024 - 12:17 UTC
Update
This incident has been mitigated; we are now seeing requests succeeding to the Claude 3.5 Sonnet model in Copilot.
Posted Nov 25, 2024 - 12:17 UTC
Update
The team is continuing to investigate errors using the Claude 3.5 Sonnet v2 model and has engaged our partners.
All requests to this model are failing, but other Copilot models are functional and can be used as an alternative.
Posted Nov 25, 2024 - 11:44 UTC
Update
Users cannot use the Claude 3.5 Sonnet model in GitHub Copilot currently, in both VS Code and GitHub.com chat. The team is investigating.