GitHub header

Disruption with some GitHub services

Incident Report for GitHub

Resolved

On February 16th, 2025 from 11:30 UTC to 12:44 UTC, API requests to GitHub.com experienced increased latency and failures. Around 1% of API requests failed at the peak of this incident.

This outage was caused by an experimental feature that malfunctioned and generated excessive database latency. In response to this incident, the feature has been redesigned to avoid database load which should prevent similar issues going forward.
Posted Feb 16, 2025 - 12:44 UTC

Update

Pull Requests is operating normally.
Posted Feb 16, 2025 - 12:43 UTC

Update

Webhooks is operating normally.
Posted Feb 16, 2025 - 12:43 UTC

Update

API Requests is operating normally.
Posted Feb 16, 2025 - 12:43 UTC

Update

Issues is operating normally.
Posted Feb 16, 2025 - 12:42 UTC

Update

Codespaces is operating normally.
Posted Feb 16, 2025 - 12:42 UTC

Update

Git Operations is operating normally.
Posted Feb 16, 2025 - 12:42 UTC

Update

Actions is operating normally.
Posted Feb 16, 2025 - 12:42 UTC

Update

Pull Requests is experiencing degraded performance. We are continuing to investigate.
Posted Feb 16, 2025 - 12:24 UTC

Update

API Requests is experiencing degraded performance. We are continuing to investigate.
Posted Feb 16, 2025 - 12:10 UTC

Investigating

We are investigating reports of degraded performance for Actions, Codespaces, Git Operations, Issues and Webhooks
Posted Feb 16, 2025 - 12:08 UTC
This incident affected: Git Operations, Webhooks, API Requests, Issues, Pull Requests, Actions, and Codespaces.