GitHub header

Git operations for users in the west coast are experiencing an increase in latency

Incident Report for GitHub

Update

We are working to enable a new network path in the west coast to reduce load and will monitor the impact on latency for Git Operations
Posted Mar 19, 2026 - 18:27 UTC

Update

We are still seeing elevated latency for Git operations in the west coast and are continuing to investigate
Posted Mar 19, 2026 - 17:49 UTC

Update

We are redirecting traffic back to our Seattle region and customers should see a decrease in latency for Git operations
Posted Mar 19, 2026 - 17:01 UTC

Investigating

We are investigating reports of degraded performance for Git Operations
Posted Mar 19, 2026 - 16:25 UTC
This incident affects: Git Operations.