On July 16th, 2024, between 00:30 UTC and 03:07 UTC, Copilot Chat was degraded and rejected all requests. The error rate was close to 100% during this time period and customers would have received errors when attempting to use Copilot Chat.
This was triggered during routine maintenance from a service provider, when GitHub services were disconnected and overwhelmed the dependent service during reconnections.
To mitigate the issue in the future, we are working to improve our reconnection and circuit-breaking logic to dependent services to recover from this kind of event seamlessly, without overwhelming the other service.
Posted Jul 16, 2024 - 03:07 UTC
Update
Copilot chat is error rates are improving and we are continuing to monitor system health.
Posted Jul 16, 2024 - 02:56 UTC
Update
Copilot chat is experiencing elevated error rates. We have identified the root cause and are working on remediation.
Posted Jul 16, 2024 - 02:10 UTC
Update
Copilot chat is experiencing elevated error rates and we are currently investigating the issue.