Between approximately 21:41 UTC July 28th and 03:15 UTC July 29th, GitHub Enterprise Importer (GEI) operated in a degraded state where migrations could not be processed.
Our investigation found that a component of the GEI infrastructure had been improperly taken out of service and could not be restored to its previous configuration. This necessitated the provisioning of new resources to resolve the incident.
As a result, customers will need to add our new IP range to the following IP allow lists, if enabled: - The IP allow list on your destination GitHub.com organization or enterprise - If you're running migrations from GitHub.com, the IP allow list on your source GitHub.com organization or enterprise - If you're running migrations from a GitHub Enterprise Server, Bitbucket Server or Bitbucket Data Center instance, the allow list on your configured Azure Blob Storage or -- Amazon S3 storage account - If you're running migrations from Azure DevOps, the allow list on your Azure DevOps organization
The new GEI IP ranges for inclusion in applicable IP allow lists are: - 20.99.172.64/28 - 135.234.59.224/28
The following IP ranges are no longer used by GEI and can be removed from all applicable IP allow lists: - 40.71.233.224/28 - 20.125.12.8/29
Users who have run migrations using GitHub Enterprise Importer in the past 90 days will receive email alerts about this change.
Posted Jul 29, 2025 - 03:15 UTC
Update
This incident is resolved, we will follow up with a detailed root cause analysis as soon as possible.
As part of mitigation, some existing IP ranges were replaced. Migrations with customer owned storage that have IP allow lists enabled will require adding new IP ranges to your IP allow lists to prevent migrations from failing. - 20.99.172.64/28 - 135.234.59.224/28
Posted Jul 29, 2025 - 03:15 UTC
Update
We have deployed mitigations and are working to verify.
Posted Jul 29, 2025 - 02:32 UTC
Update
The team is continuing its work to mitigate this incident.
Posted Jul 29, 2025 - 01:23 UTC
Update
We're continuing to work to mitigate this issue, customers will continue to see stalled migrations in the meantime.
Posted Jul 29, 2025 - 00:45 UTC
Update
We continue to work to mitigate this issue.
Posted Jul 28, 2025 - 23:24 UTC
Update
We are still working to mitigate the issue.
Posted Jul 28, 2025 - 22:49 UTC
Update
We have identified the issue and we're working to mitigate.