GitHub header

GitHub search is degraded

Incident Report for GitHub

Update

Pull Requests is experiencing degraded availability. We are continuing to investigate.
Posted Apr 27, 2026 - 18:19 UTC

Update

We're continuing to see connectivity issues reaching elasticsearch. Impact on downstream services will be intermittent as we find the root cause
Posted Apr 27, 2026 - 18:17 UTC

Update

Users are experiencing intermittent failures to view issues, pull requests, projects and Actions workflow runs.

We are still investigating and attempting mitigations. We will provide further updates.
Posted Apr 27, 2026 - 17:35 UTC

Update

Pull Requests is experiencing degraded performance. We are continuing to investigate.
Posted Apr 27, 2026 - 16:53 UTC

Update

Packages is experiencing degraded performance. We are continuing to investigate.
Posted Apr 27, 2026 - 16:39 UTC

Update

Issues is experiencing degraded performance. We are continuing to investigate.
Posted Apr 27, 2026 - 16:36 UTC

Update

Customers across GitHub are experiencing failures with searches. Examples include: workflow run failures, projects failing to load, and timed out search requests. This is due to an ongoing infrastructure issue that we have been investigating.
Posted Apr 27, 2026 - 16:33 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Apr 27, 2026 - 16:31 UTC
This incident affects: Issues, Pull Requests, Actions, and Packages.