GitHub header
Incident with Actions, API Requests, Copilot and Git Operations
Incident Report for GitHub
Resolved
This incident has been resolved.
Posted Apr 25, 2023 - 03:18 UTC
Update
We are continuing to work towards mitigating the connection resets and connection timeouts that some clients located in West US are experiencing.
Posted Apr 25, 2023 - 03:08 UTC
Update
Starting at 20:30 UTC, a small % of clients in West US are seeing connection resets or connection timeouts, leading to failed action downloads. We are continuing to work to identify a mitigation.
Posted Apr 25, 2023 - 01:31 UTC
Update
Copilot is operating normally.
Posted Apr 25, 2023 - 00:13 UTC
Update
We continue to investigate an issue causing fewer than 1% of workflow runs on GitHub-hosted runners to fail.
Posted Apr 24, 2023 - 23:14 UTC
Update
API Requests is experiencing degraded performance. We are still investigating and will provide an update when we have one.
Posted Apr 24, 2023 - 22:33 UTC
Update
Git Operations is experiencing degraded performance. We are still investigating and will provide an update when we have one.
Posted Apr 24, 2023 - 22:29 UTC
Update
We are actively investigating an issue causing fewer than 1% of workflow runs on GitHub-hosted runners to fail.
Posted Apr 24, 2023 - 22:17 UTC
Update
We are actively investigating an issue causing fewer than 1% of Copilot code suggestions to time out.
Posted Apr 24, 2023 - 22:03 UTC
Update
Actions is experiencing degraded performance. We are still investigating and will provide an update when we have one.
Posted Apr 24, 2023 - 21:29 UTC
Investigating
We are investigating reports of degraded performance for Copilot.
Posted Apr 24, 2023 - 21:14 UTC
This incident affected: Git Operations, API Requests, Actions, and Copilot.