GitHub header

Disruption with Copilot Cloud Agent and Copilot Code Review

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted May 28, 2026 - 20:41 UTC

Update

Open AI models are currently unavailable. We are shifting requests to other models to reduce impact.
Posted May 28, 2026 - 20:06 UTC

Update

We are investigating errors with Copilot requests using OpenAI models
Posted May 28, 2026 - 19:40 UTC

Update

Copilot is experiencing degraded performance. We are continuing to investigate.
Posted May 28, 2026 - 19:20 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted May 28, 2026 - 19:01 UTC
This incident affected: Copilot.