GitHub header

Delays in copilot budget limits resets for some users

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Jul 01, 2026 - 13:26 UTC

Update

The fix has been deployed globally and we are monitoring the results
Posted Jul 01, 2026 - 13:05 UTC

Monitoring

The degradation affecting Copilot has been mitigated. We are monitoring to ensure stability.
Posted Jul 01, 2026 - 13:04 UTC

Update

A fix for the delayed resets is currently being deployed.
Posted Jul 01, 2026 - 12:42 UTC

Update

We have identified the likely reason for the delays and are working on a solution.
Posted Jul 01, 2026 - 11:44 UTC

Investigating

We are investigating reports of degraded performance for Copilot
Posted Jul 01, 2026 - 10:51 UTC
This incident affected: Copilot.