GitHub header
Incident with Codespaces
Incident Report for GitHub
Resolved
On December 26, 2023, GitHub received a report through our Bug Bounty Program demonstrating a vulnerability which, if exploited, allowed access to credentials within a production container. We fixed this vulnerability on GitHub.com the same day and began rotating all potentially exposed credentials. Through this process we found some flaws in how we rotate certain credentials and are working on improving our credential rotation process. More detail can be found on our blog: https://github.blog/2024-01-16-rotating-credentials-for-github-com-and-new-ghes-patches/
Posted Dec 27, 2023 - 04:00 UTC
Update
We have applied a fix and most customers should now be seeing recovery.
Posted Dec 27, 2023 - 03:57 UTC
Update
Customers using Codespaces will be unable to connect to existing codespaces, create new ones, or export. We have identified the issue and are working on a remediation.
Posted Dec 27, 2023 - 03:14 UTC
Update
Codespaces is experiencing degraded availability. We are continuing to investigate.
Posted Dec 27, 2023 - 03:09 UTC
Update
Codespace services are experiencing connection issues
Posted Dec 27, 2023 - 02:53 UTC
Investigating
We are investigating reports of degraded availability for Codespaces
Posted Dec 27, 2023 - 02:53 UTC
This incident affected: Codespaces.