GitHub header
Incident with Pull Requests
Incident Report for GitHub
Resolved
On September 14th, 2024 from 20:45 UTC to 22:31 UTC commit creation operations, most commonly Pull Request merges, failed for some repositories. 226 repositories were impacted.

The root cause was a hardware fault in a Git file server, where merge commits are calculated. To mitigate the issue we marked the file server as offline.

Detection was slower than is typical because of lower weekend traffic. We’re making improvements to monitoring to decrease time to detection in future.
Posted Sep 14, 2024 - 22:43 UTC
Update
Pull Requests is operating normally.
Posted Sep 14, 2024 - 22:43 UTC
Update
we believe we have mitigated and are confirming recovery.
Posted Sep 14, 2024 - 22:41 UTC
Investigating
We are investigating reports of degraded performance for Pull Requests
Posted Sep 14, 2024 - 22:10 UTC
This incident affected: Pull Requests.