On July 31st, 2024, between 00:31 UTC and 03:37 UTC the Codespaces service was degraded and connecting through non-web flows such as VS Code or the GitHub CLI were unavailable. Using Codespaces via the web portal was not impacted. This was due to a code change resulting in authentication failures from the Codespaces public API.
We mitigated the incident by reverting the change upon discovering the cause of the issue.
We are working to improve testing, monitoring, and rollout of new features to reduce our time to detection and mitigation of issues like this one in the future.
Posted Jul 31, 2024 - 03:37 UTC
Update
The team is currently investigating a fix for issues with Codespaces. Impact continues to be limited to non-web clients. Customers receiving errors on desktop clients are encouraged to use the web client as a temporary workaround.
Posted Jul 31, 2024 - 02:55 UTC
Update
We continue investigating issues with Codespaces in multiple regions. Impact is limited to non-web clients. Customers receiving errors on desktop clients are encouraged to use the web client as a temporary workaround.
Posted Jul 31, 2024 - 01:49 UTC
Update
We are investigating issues with Codespaces in multiple regions. Some users may not be able to connect to their Codespaces at this time. We will update you on mitigation progress.
Posted Jul 31, 2024 - 01:23 UTC
Update
We are investigating reports of degraded performance for Codespaces.
Posted Jul 31, 2024 - 00:53 UTC
Investigating
We are investigating reports of degraded performance for Codespaces