At 15:33 UTC on August 5, 2025, we initiated a production database migration to drop a column from a table backing pull request functionality. While the column was no longer in direct use, our ORM continued to reference the dropped column in a subset of pull request queries. As a result, there were elevated error rates across pushes, webhooks, notifications, and pull requests with impact peaking at approximately 4% of all web and REST API traffic.
We mitigated the issue by deploying a change that instructed the ORM to ignore the removed column. Most affected services recovered by 16:13 UTC. However, that fix was applied only to our largest production environment. An update to some of our custom and canary environments did not pick up the fix and this triggered a secondary incident affecting ~0.1% of pull request traffic, which was fully resolved by 19:45 UTC.
While migrations have protections such as progressive roll-out first targeting validation environments and acknowledge gates, this incident identified an application monitoring gap that would have prevented continued rollout when impact was observed. We will add additional automation and safeguards to prevent future incidents without requiring human intervention. We are also already working on a way to streamline some types of changes across environments, which would have prevented the second incident from occurring.
Posted Aug 05, 2025 - 19:46 UTC
Update
Pull Requests is operating normally.
Posted Aug 05, 2025 - 19:46 UTC
Update
We continue to investigate issues with PRs. Impact remains limited to less than 2% of users.
Posted Aug 05, 2025 - 19:20 UTC
Update
We continue to investigate issues with PRs impacting less than 2% of customers.
Posted Aug 05, 2025 - 18:49 UTC
Update
We continue to investigate issues with PRs impacting less than 2% of customers.
Posted Aug 05, 2025 - 18:23 UTC
Update
We're seeing issues related to PR are investigating. Less than 2% of users are impacted.
Posted Aug 05, 2025 - 18:07 UTC
Investigating
We are investigating reports of degraded performance for Pull Requests