GitHub header
Incident with Codespaces
Incident Report for GitHub
Resolved
On May 23, 2024 between 15:31 and 16:02 the Codespaces service reported a degraded experience in codespaces across all regions. Upon further investigation this was found to be an error reporting issue and did not have user facing impact. The new error reporting that was implemented began raising on existing non-user facing errors that are handled further in the flow, at the controller level, which do not cause user impact. We are working to improve our reporting roll out process to reduce issues like this in the future which includes updating monitors and dashboards to exclude this class of error. We are also reclassifying and correcting internal API responses to better represent when errors are user facing for more accurate reporting.
Posted May 23, 2024 - 16:02 UTC
Update
We are investigating increased error rates for customers attempting to start Codespaces across all regions, around 15% of attempts are affected. Any affected customers may attempt to retry starting their Codespace. We are continuing to investigate.
Posted May 23, 2024 - 15:41 UTC
Investigating
We are investigating reports of degraded performance for Codespaces
Posted May 23, 2024 - 15:31 UTC
This incident affected: Codespaces.