GitHub header

Incident with Codespaces

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Mar 09, 2026 - 03:51 UTC

Update

This incident has been resolved. New Codespace creation requests are now completing successfully.
Posted Mar 09, 2026 - 03:51 UTC

Update

We are seeing recovery, with the failure rate for new Codespace creation requests dropping from 5% to about 3%.
Posted Mar 09, 2026 - 03:32 UTC

Update

We are seeing about 5% of new Codespace creation requests failing. We are investigating the root cause and identifying the impacted regions.
Posted Mar 09, 2026 - 03:04 UTC

Investigating

We are investigating reports of degraded performance for Codespaces
Posted Mar 09, 2026 - 03:04 UTC
This incident affected: Codespaces.