GitHub header

Claude 3.7 Sonnet Partially Unavailable

Incident Report for GitHub

Resolved

On February 25, 2025 between 13:40 UTC and 15:45 UTC the Claude 3.7 Sonnet model for GitHub Copilot Chat experienced degraded performance. During the impact, occasional requests to Claude would result in an immediate error to the user. This was due to upstream errors with one of our infrastructure providers, which have since been mitigated.

We are working with our infrastructure providers to reduce time to detection and implement additional failover options, to mitigate issues like this one in the future.
Posted Feb 25, 2025 - 15:45 UTC

Update

We have disabled Claude 3.7 Sonnet models in Copilot Chat and across IDE integrations (VSCode, Visual Studio, JetBrains) due to an issue with our provider.

Users may still see these models as available for a brief period but we recommend switching to a different model. Other models were not impacted and are available.

Once our provider has resolved the issues impacting Claude 3.7 Sonnet models, we will re-enable them.
Posted Feb 25, 2025 - 15:25 UTC

Update

Copilot is experiencing degraded performance. We are continuing to investigate.
Posted Feb 25, 2025 - 14:44 UTC

Update

We are currently experiencing partial availability for the Claude 3.7 Sonnet and Claude 3.7 Thinking models in Copilot Chat, VSCode and other Copilot products. This is due to problems with an upstream provider. We are working to resolve these issues and will update with more information as it is made available.

Other Copilot models are available and working as expected.
Posted Feb 25, 2025 - 14:43 UTC

Investigating

We are currently investigating this issue.
Posted Feb 25, 2025 - 14:40 UTC
This incident affected: Copilot.