On July 2, 2025, between 1:35 AM UTC and 16:23 UTC, the GitHub Enterprise Importer (GEI) migration service experienced degraded performance and slower-than-normal migration queue processing times. This incident was triggered due to a migration including an abnormally large number of repositories, overwhelming the queue and slowing processing for all migrations.
We mitigated the incident by removing the problematic migrations from the queue. Service was restored to normal operation as the queue volume was reduced.
To ensure system stability, we have introduced additional concurrency controls that limit the number of queued repositories per organization migration, helping to prevent similar incidents in the future.
Posted Jul 02, 2025 - 16:23 UTC
Update
We're down to healthy level of queued migrations and the system is processing migrations at normal system concurrency levels.
Posted Jul 02, 2025 - 16:23 UTC
Update
Repository migrations are experiencing delayed processing times. Mitigation has been implemented and migration times are recovering.